Androidでライブラリメソッド数超過

ORMapperのUnitTestを追加しようとしたら、
Multi dex installation failed. SDK 1 is unsupported. Min SDK version is 4.
とエラー。
com.android.dex.DexIndexOverflowException
って場合もある。

以下で回避できた
http://www.jiahaoliuliu.com/2015/02/android-robolectric-solving-multidex.html

Googleの提供するSDKはでかすぎるから、分割提供もしているらしい。

Google Play系SDKを全て突っ込んでるケースが以下
compile ‘com.google.android.gms:play-services:+’

それをMobile Ads SDKだけにしたのが以下
compile ‘com.google.android.gms:play-services-ads:8.3.0’

20000くらいがGoogle SDK関連のようなのでかなり効果あった(12000くらい節約でけた)。